Qué hay de nuevo

Recuperar Boot: VU+ DUO / SOLO / ONE Multiboot CFE Problemas

CoPeRniX

STAFF
Miembro del equipo
STAFF
RESTORE PROCEDURE

Posiblemente a la hora de utilizar Multiboot-v36l-CFE-all o algunas de sus versiones has tenido problemas, aquí la solución:

Deberemos utilizar el software PuTTY usando el puerto RS232.

Debes de hacer lo siguiente:

1) Arranque Putty y configurelo con estos datos (115200,8,n,1), conecte su cable Null Modem al puerto RS232 del ordenador y VU+, arranque su VU+.

2) Lance este comando desde Putty.


Código:
[COLOR=#ff0000][B][B]boot -z -elf flash0.kernel: 'rootfstype=jffs2 root=/dev/mtdblock0 rw mem=0x8000000 bcmrac=3`[/B][/B][/COLOR]
3)Ahora su VU debe arrancar desde la Flash

4) Vuelva a conectar con Putty y lance ahora este nuevo comando.

Código:
[COLOR=#ff0000][B][B]flash_eraseall /dev/mtd5[/B][/B][/COLOR]
5) Reinicie su VU+
Terminado el proceso, ahora su VU+ debe arrancar sin problemas.

This procedure has been made by black_64, tnk you.
 

angel1975

New member
buenas tardes,

me podrias decir como enviar comandos desde putty, al conectar el vu con putty me sale una pantalla que no me deja escribir, y no se como enviar el comando. garcias de antemano
 

CoPeRniX

STAFF
Miembro del equipo
STAFF
Buenas compañero,

Has probado antes de nada volver a cargar el kernel y la imagen de nuevo ?? Si ya has hecho eso:

Primero revisa en el administrador de dispositivos en que puerto de serie tienes conectado el cable null modem y asegúrate que sea null modem, sino no nos conectará. Posteriormente procederemos a la configuración de Putty:

1.jpg 2.jpg

Tendrías que poder seguir el manual sin problemas.

Gracias,
Saludos.
 

angel1975

New member
Buenas tardes,

Hoy se me a vuelto a quedar el vu duo es starting, he vuelto a seguir todos los pasos pero al conectar con putty me sale este mensaje;



BCM73350010
012
Shmoo Version=1.9


MEMC-00000000 RW=00000012 WW=0000004C G=00000001 R=00000009 W=00000011
MEMC-00000001 RW=00000010 WW=0000005B G=00000001 R=00000008 W=00000003 #$
3
COPY CODE
A567


BCM97335B0 CFE v2.17, CFE core v2.12, Endian Mode: Little
Build Date: Thu Sep 29 12:01:32 2011 (shcheong@ncsh)
Copyright (C) Broadcom Corporation.


writing vfd


DDR Freq: 395MHz
CPU speed: 405MHz
Memory Config: 32+16 non-UMA
Device Tech: 2Gb
Total memory: 768MB
Boot Device: NAND
ECC: Hamming
Total flash: 128MB


Initializing USB.
**Exception 32: EPC=8701D8E8, Cause=0000801C, VAddr=00000000
RA=8701DB28, PRID=0002A044


0 ($00) = 00000000 AT ($01) = B0480000
v0 ($02) = 00000000 v1 ($03) = 87020000
a0 ($04) = B0480400 a1 ($05) = 87040000
a2 ($06) = B0480390 a3 ($07) = 00000000
t0 ($08) = 00000043 t1 ($09) = 00000055
t2 ($10) = 00000046 t3 ($11) = 87069570
t4 ($12) = 00000001 t5 ($13) = 870470E8
t6 ($14) = 00000000 t7 ($15) = 07600000
s0 ($16) = 8701D8CC s1 ($17) = B0480400
s2 ($18) = 8700A4B8 s3 ($19) = 38C00000
s4 ($20) = 00008000 s5 ($21) = 00000040
s6 ($22) = 00010000 s7 ($23) = 00000040
t8 ($24) = 00000000 t9 ($25) = 870471F4
k0 ($26) = 00000000 k1 ($27) = 00000000
gp ($28) = 8704E210 sp ($29) = 87148768
fp ($30) = BFC00AA0 ra ($31) = 8701DB28




*** Waiting for system reset ***

Y de hay no se nueve, me podríais ayudar, gracias
 

coffe

New member
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
Registering unionfs 2.5.11 (for 3.1.10)
NTFS driver 2.1.30 [Flags: R/W].
JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
msgmni has been set to 207
io scheduler noop registered
io scheduler cfq registered (default)
Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x10400b00 (irq = 22) is a 16550A
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
serial8250.0: ttyS1 at MMIO 0x10400b40 (irq = 66) is a 16550A
loop: module loaded
Broadcom STB NAND controller (BrcmNand Controller)
bcmemac: Broadcom STB 10/100 EMAC driver v3.0
bcmemac: registered interface #0 at 0x10080000 as 'eth0' (00:de:fa:11:73:b0)
usbcore: registered new interface driver zd1201
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
brcm-pm: enabling usb clocks
ehci-brcm ehci-brcm.0: Broadcom STB EHCI
ehci-brcm ehci-brcm.0: new USB bus registered, assigned bus number 1
ehci-brcm ehci-brcm.0: irq 62, io mem 0x10480300
ehci-brcm ehci-brcm.0: USB 0.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
ehci-brcm ehci-brcm.1: Broadcom STB EHCI
ehci-brcm ehci-brcm.1: new USB bus registered, assigned bus number 2
ehci-brcm ehci-brcm.1: irq 63, io mem 0x10480500
ehci-brcm ehci-brcm.1: USB 0.0 started, EHCI 1.00
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ohci-brcm ohci-brcm.0: Broadcom STB OHCI
ohci-brcm ohci-brcm.0: new USB bus registered, assigned bus number 3
ohci-brcm ohci-brcm.0: irq 64, io mem 0x10480400
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 1 port detected
ohci-brcm ohci-brcm.1: Broadcom STB OHCI
ohci-brcm ohci-brcm.1: new USB bus registered, assigned bus number 4
ohci-brcm ohci-brcm.1: irq 59, io mem 0x10480600
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
mousedev: PS/2 mouse device common for all mice
i2c /dev entries driver
Success! Registering the characther device success with 0
blackhole initialised
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
ALSA device list:
No soundcards found.
TCP cubic registered
NET: Registered protocol family 17
lib80211: common routines for IEEE802.11 drivers
EBI CS0: setting up NAND flash (primary)
mtd->oobsize=0, mtd->eccOobSize=0
NAND_CS_NAND_XOR=00000001
B4: NandSelect=40000101, nandConfig=55042200, chipSelect=0
brcmnand_read_id: CS0: dev_id=ecf10095
After: NandSelect=40000101, nandConfig=55042200
Block size=00020000, erase shift=17
NAND Config: Reg=55042200, chipSize=128 MB, blockSize=128K, erase_shift=11
busWidth=1, pageSize=2048B, page_shift=11, page_mask=000007ff
BrcmNAND mfg ec f1 Samsung K9F1G08U0A 128MB on CS0

Found NAND on CS0: ACC=d3000000, cfg=55042200, flashId=ecf10095, tim1=4232222d, tim2=00000d94
BrcmNAND version = 0x0200 128MB @00000000
B4: NandSelect=40000101, nandConfig=55042200, chipSelect=0
brcmnand_read_id: CS0: dev_id=ecf10095
After: NandSelect=40000101, nandConfig=55042200
Found NAND flash on Chip Select 0, chipSize=128MB, usable size=128MB, base=0
brcmnand_scan: B4 nand_select = 40000101
brcmnand_scan: After nand_select = 40000101
page_shift=11, bbt_erase_shift=17, chip_shift=27, phys_erase_shift=17
Brcm NAND controller version = 2.0 NAND flash size 128MB @18000000
ECC layout=brcmnand_oob_bch4_4k
brcmnand_scan: mtd->oobsize=64
brcmnand_scan: oobavail=50, eccsize=512, writesize=2048
brcmnand_scan, eccsize=512, writesize=2048, eccsteps=4, ecclevel=15, eccbytes=3
-->brcmnand_default_bbt
brcmnand_default_bbt: bbt_td = bbt_main_descr
Creating 7 MTD partitions on "brcmnand.0":
0x000000000000-0x000007400000 : "rootfs"
0x000007400000-0x000007800000 : "kernel"
0x000007800000-0x000007c00000 : "boot"
0x000007c00000-0x000007d00000 : "cfe"
0x000007d00000-0x000007d80000 : "mac"
0x000007d80000-0x000007e00000 : "env"
0x000007e00000-0x000007f00000 : "nvm"
UBI: attaching mtd0 to ubi0
UBI: physical eraseblock size: 131072 bytes (128 KiB)
UBI: logical eraseblock size: 126976 bytes
UBI: smallest flash I/O unit: 2048
UBI: VID header offset: 2048 (aligned 2048)
UBI: data offset: 4096
UBI: max. sequence number: 255
UBI: attached mtd0 to ubi0
UBI: MTD device name: "rootfs"
UBI: MTD device size: 116 MiB
UBI: number of good PEBs: 924
UBI: number of bad PEBs: 4
UBI: number of corrupted PEBs: 0
UBI: max. allowed volumes: 128
UBI: wear-leveling threshold: 4096
UBI: number of internal volumes: 1
UBI: number of user volumes: 1
UBI: available PEBs: 0
UBI: total number of reserved PEBs: 924
UBI: number of PEBs reserved for bad PEB handling: 9
UBI: max/mean erase counter: 2/0
UBI: image sequence number: 159440781
UBIFS: parse sync
UBI: background thread "ubi_bgt0d" started, PID 37
UBIFS: recovery needed
flash_eraseall /dev/mtd5UBIFS: recovery completed
UBIFS: mounted UBI device 0, volume 0, name "rootfs"
UBIFS: file system size: 114278400 bytes (111600 KiB, 108 MiB, 900 LEBs)
UBIFS: journal size: 9023488 bytes (8812 KiB, 8 MiB, 72 LEBs)
UBIFS: media format: w4/r0 (latest is w4/r0)
UBIFS: default compressor: lzo
UBIFS: reserved for root: 0 bytes (0 KiB)
VFS: Mounted root (ubifs filesystem) on device 0:12.
Freeing unused kernel memory: 208k freed

INIT: version 2.88 booting

Please wait: booting...
flash_eraseall /dev/mtd5
NET: Registered protocol family 10
procmk_init
dvb_bcm7325: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
DVB: registering new adapter (vusolo)
bcm7325: hotplug_callback():
Hotplug - status.connected 0
CPU 0 Unable to handle kernel paging request at virtual address c07c8e10, epc == c07c8e10, ra == 8005ddf0
Oops[#1]:
Cpu 0
$ 0 : 00000000 00000000 c07c8e10 00000000
$ 4 : 0000000d c0bae124 00020000 00200200
$ 8 : 11008400 1000001f 810a5514 00000001
$12 : 805c7070 805c7070 0000000a ffffffff
$16 : 864e8200 00010000 00000000 00000000
$20 : 0000000d 805a641c 805a0000 80610000
$24 : 00000000 810adc00
$28 : 86fda000 86fdbc98 8052d4c4 8005ddf0
Hi : 00000002
Lo : 318c6354
epc : c07c8e10 0xc07c8e10
Tainted: P
ra : 8005ddf0 handle_irq_event_percpu+0x78/0x298
Status: 11008002 KERNEL EXL
Cause : 10800008
BadVA : c07c8e10
PrId : 0101954c (Brcm4380)
Modules linked in: procmk ipv6
Process modprobe (pid: 272, threadinfo=86fda000, task=86f7edc8, tls=77ad1490)
Stack : 805a0000 80033354 805a0000 80610000 8052d4c4 8005de4c 805a641c 00010000
00000020 00000000 b0000000 00000002 fffffbff 00000124 8005960c 8005e048
80610000 805a3a40 00000000 8002c5bc 805a641c 800602c4 8645e884 86fdbca8
80559dd3 80559dd7 00000001 00000000 00000001 8005d6d8 00000020 00000000
b0000000 00000002 fffffbff 80005568 00000001 8002c80c 00000000 0000000a
...
Call Trace:
[<80033354>] run_timer_softirq+0x38/0x204
[<8005de4c>] handle_irq_event_percpu+0xd4/0x298
[<8005960c>] module_sect_show+0x0/0x18
[<8005e048>] handle_irq_event+0x38/0x60
[<8002c5bc>] __do_softirq+0xd0/0x15c
[<800602c4>] handle_level_irq+0x98/0x134
[<8005d6d8>] generic_handle_irq+0x48/0x58
[<80005568>] do_IRQ+0x18/0x30
[<8002c80c>] do_softirq+0x68/0x70
[<80001fe8>] plat_irq_dispatch+0xf0/0x1a4
[<800f5e18>] release_sysfs_dirent+0xa0/0x1a8
[<80003a6c>] ret_from_irq+0x0/0x4
[<800f68c0>] sysfs_addrm_finish+0x10c/0x198
[<8006d7c0>] free_hot_cold_page+0x3c/0x2cc
[<8005960c>] module_sect_show+0x0/0x18
[<8006d914>] free_hot_cold_page+0x190/0x2cc
[<8006d934>] free_hot_cold_page+0x1b0/0x2cc
[<8005960c>] module_sect_show+0x0/0x18
[<80091390>] remove_vm_area+0xe4/0x104
[<80091458>] __vunmap+0x70/0x128
[<80048fbc>] blocking_notifier_call_chain+0x14/0x20
[<8005ad30>] sys_init_module+0x6fc/0x1c94
[<80099ce0>] filp_close+0x78/0xa4
[<8000bde4>] stack_done+0x20/0x40
[<8027de18>] __bzero+0xbc/0x164


Code: (Bad address in epc)

---[ end trace fe0a0deb3e09dd5b ]---
Kernel panic - not syncing: Fatal exception in interrupt
Rebooting in 180 seconds..
 

CoPeRniX

STAFF
Miembro del equipo
STAFF
Buenas coffe,

Si se trata de un DUO o solo, prueba de flashear el boot y posteriormente la imagen que desees, prueba con BlackHole o bien la oficial. Si no arranca, vuelve a lanzar los comando y revisamos :).
 

litri666

New member
saludos , me encuentro con el mismo problema , esta mañana me encontre la vu+duo con el displai en starring , la apàgue y me marche , al llegar esta tarde la enciendo del interruptor y nada , piloto en rojo y no se mueve de ahy , estoy intentando conectar con el putyyn y no ahy forma , intento cargarle una nueva imagen por usb y nada , no ahy forma de tener conexion con ella , que puedo hacer ? , gracias chicos
 

dosky

Well-known member
Miembro del equipo
STAFF
¿Tampoco puedes conectar por cable nullmodem a través del puerto rs232? Con el vu+ util

Saludos
 

juanen

Active member
si tienes el piloto rojo encendido enm el display va a ser cosa del condensador de marras
saludosss
 

litri666

New member
no conecto de ninguna forma por rs232 , el cable null esta testeado con otro aparato y funciona bien , lo extraño es que se quedo en starring y tuve que apagar y al encender , piloto rojo y no sale de ahy , e intentado con putyyn y con vu+util y nada de nada
 

juanen

Active member
y si es problema de condensador , donde puedo mandarlo a que me lo reparen ? , un saludo y gracias[/QUOTE ]

tienes varias opciones, si lo tienes en garantia sin duda dondle lo compraste ysi no es asi puedes mandarlo igualmente eso si a tu cargo la reparacion
tb puedes en la tienda de barrio no es gran cosa, haber si te subo alguna imagen, por aqui tienes el manual , ahora no lo encuentro ,pero te lo subire
saludos
 

litri666

New member
solucionado , gracias juanen por tu ayuda , la verdad que a sido cambiarlo y a rular , ahora es cuestion de tener siempre a mano unos de repuesto jajjajajaj, muchas gracias a todos
 
Arriba